Today is...
Sunday, December 16, 2018
Welcome to the Modbus Community, about
the world's leading automation protocol.
Modbus Addressing in Weintek HMI
Modbus Addressing in HMI to poll data from Temperature sensor through RS485

Modbus addressing in Weintek HMI to poll data from Temperature sensor through RS485. In my system i have connected Temperature sensor to I/O Scanner has output in terms of RS-485 which directly connected to COM3 Port pin. No. 6 (as Negative) & 9 (as Positive) of HMI (Model No: MT8071iE) and HMI connected to PC via ETHERNET.

I want to read temp on HMI screen via MODBUS protocol.

So, can you please provide me instruction about addressing of MODBUS register in Easy-Builder Software so can read data of corresponding register. Because when i do compile i got an error like " Device no Response".

I hope i got reply from your side as Fast as possible to overcome this problem.

Thank you.

You have to configure the HMI as a Modbus gateway. The manual has a section on this. Then you have to configure a Modbus master in the system parameter menu. Make sure that your baud rate, protocol, parity and slave address are correct.

First of all Thank you for replying me.

I tried all MODBUS TCP/IP Gateway, but still it shows same error as my parameter parity bit, baudrate, com port all are correct.

Try scanning the slave device with modscan and see if you can communicate with it. If not, then try another cable to eliminate a bad or miswired connection.

As you said, I already tried with Modscan32 application in which i got temperature data for corresponding register, but not get on HMI screen.

Here's a link to the manual:
https://www.weintek.com/globalw/Download/Download.aspx?T=hardware

As the other responder said, you first make the device available by establishing a comm type under system. Since it supports many protocols, this allows the HMI to know which protocol type to point to. Your Modbus specifics are set up there. once set, specific addresses inside that device are mapped either object by object or configured in the tag library then accessed where needed (so any address change is made in one place and is applied to multiple screen objects). There are probably Youtube videos to help, but its probably read-the-manual and trial and error to get there.

good luck

Also, make sure that your Modbus master and slave object are configured as local and not remote. Remote in this context means that the HMI will try to communicate thru another HMI and then to the slave device.